OSPFv3 Setting Cisco

הקדמה:

OSPF

פרוטוקול הנתיב הקצר ביותר הראשון או פרוטוקול OSPF הוא IGP של מצב קישור שהותאם במיוחד לרשתות IP באמצעות האלגוריתם ה- Shortest Path First (SPF). אלגוריתם הניתוב של SPF משמש לחישוב הנתיב הקצר ביותר המשתרע על-מנת להבטיח העברת נתונים יעילה של מנות. נתבי OSPF מנהלים מאגרי מידע המפרטים מידע על הטופולוגיה הסובבת של הרשת. מסד נתונים זה מלא בנתונים שנלקחו מפרסומי Link State (LSA) שנשלחו על ידי נתבים אחרים. LSAs הם חבילות המפרטות מידע על כמה משאבים שייקח נתיב נתון.

פרמטרים שניצטרך להכיר:

OSPF Area

אזור הוא קבוצה של רשתות ומארחים בתוך AS שקובצו יחד מנהלית. מכשירי ניתוב הנמצאים במלואם באזור נקראים נתבים פנימיים. כל הממשקים בנתבים פנימיים מחוברים ישירות לרשתות באזור. הטופולוגיה של האזור מוסתרת משאר אזורי ה- AS, ובכך מפחיתה משמעותית את תעבורת הניתוב ב- AS. כמו כן, ניתוב בתוך האזור נקבע רק על ידי הטופולוגיה של האזור, ומספק לאזור הגנה מסוימת מפני נתוני ניתוב גרועים. לכל מכשירי הניתוב באזור ישנם מאגרי מידע טופולוגיים זהים.

OSPF Border Routers

מכשירי ניתוב השייכים ליותר מאזור אחד ומחברים אזור אחד או יותר של OSPF לאזור עמוד השדרה נקראים נתיבי גבול אזוריים (ABR) לדוגמא, אם יש לנו קבוצה של נתבים שלכל קבוצה יש קוד Area , כל נתב שמחבר בין אזור לאזור יקרא border area או לחילופין ARB(Area Border Routers) שאותם אנו מכנים BackBone אזור עמוד השדרה של אותו איזור ניתוב

LSA

פונקציית הקצב הקבוצתי של OSPF LSA מאפשרת לנתב לקבץ OSPF LSA ולקצב את פונקציות הרענון, הסיכום וההזדקנות לשימוש יעיל יותר בנתב. תכונה זו מופעלת כברירת מחדל עם מרווח ברירת מחדל של 4 דקות לקצב, ולרוב לא תצטרך לשנות פרמטר זה. מרווח הצעדים הקבוצתי האופטימלי הוא ביחס הפוך למספר ה- LSA שהנתב מרענן, מסכם בדיקות ומזדקן. לדוגמה, אם יש לך כ -10,000 LSA במסד הנתונים, הפחתת מרווח הקצב תועיל לך. אם יש לך בסיס נתונים קטן מאוד (40 עד 100 LSA), הגדלת מרווח הקצב ל 10 עד 20 דקות עשויה להועיל לך מעט.

LoopBack interfaces

OSPF משתמש בכתובת ה- IP הגבוהה ביותר שהוגדרה בממשקים כמזהה Router-id X.X.X.X. אם ה interface שמחבר בין הנתבים נופל או נמחק , ה- OSPF יחשב מחדש את מזהה הנתב מחדש router-id וילשלוח מחדש את כל פרטי הניתוב שלו דרך interface אחר אם מוגדר ממשק loopback עם כתובת IP, OSPF משתמש בכתובת IP זו כמזהה הנתב שלה, גם אם לממשקים אחרים יש כתובות IP גבוהות יותר. מכיוון שממשקי loopback לעולם אינם נכשלים, הדבר מספק יציבות רבה יותר. OSPF מעדיף אוטומטית ממשק loopback על פני ממשקים אחרים, והוא בוחר את כתובת ה- IP הגבוהה ביותר מבין כל ממשקי ה- loopback.

לצורך התרגיל נדמה 3 איזורים עם ניתוב OSPF

הגדרת Router :

Area 0 router 1

R1 >R5 192.168.11.1/24

R1 >R3 192.168.13.1/24

R1 >R2 192.168.12.1/24

R1(config)#interface gigabitEthernet  0/0
R1(config-if)#ip address 192.168.11.1   255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface gigabitEthernet  0/1
R1(config-if)#ip address 192.168.13.1   255.255.255.0
R1(config-if)#no shutdown

R1(config)#interface gigabitEthernet  0/2
R1(config-if)#ip address 192.168.12.1   255.255.255.0
R1(config-if)#no shutdown


## הגדרת ה OSPF
R1(config)#router ospf 1
R1(config-router)#network 192.168.11.0  0.0.0.255  area 0
R1(config-router)#network 192.168.12.0  0.0.0.255  area 1
R1(config-router)#network 192.168.13.0  0.0.0.255  area 1
R1(config-router)#router-id 1.1.1.1

Area 1 Router 3

R3>R1 192.168.13.2/24

R2 >R1 192.168.12.2/24

R1(config)#interface gigabitEthernet  0/0
R1(config-if)#ip address 192.168.13.2   255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#interface gigabitEthernet 0/1
R1(config-if)#ip address 192.168.3.1    255.255.255.0

## הגדרת ה OSPF
R1(config)#router ospf 1
R1(config-router)#network 192.168.11.0  0.0.0.255  area 0
R1(config-router)#network 192.168.12.0  0.0.0.255  area 1
R1(config-router)#network 192.168.13.0  0.0.0.255  area 1
R1(config-router)#router-id 3.3.3.3

Area 1 Router 2

R5 >R6 192.168.14.0/24

R5 >R7 192.168.12.0/24

R1(config)#interface gigabitEthernet  0/0
R1(config-if)#ip address 192.168.12.2   255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#interface gigabitEthernet 0/1
R1(config-if)#ip address 192.168.2.1    255.255.255.0

## הגדרת ה OSPF
R1(config)#router ospf 1
R1(config-router)#network 192.168.11.0  0.0.0.255  area 0
R1(config-router)#network 192.168.12.0  0.0.0.255  area 1
R1(config-router)#network 192.168.13.0  0.0.0.255  area 1
R1(config-router)#router-id 2.2.2.2

כעת נבצע בדיקה לצד שמאל שלנו נבדור את אזור 1 ו 2 שבנינו

R1#show ip ospf neighbor

ניתן לראות שאנחנו רואים את הניתוב ומזהים את טופולוגיית הרשת

DR (Designated Router)

BDR (Backup Designated Router)

Area 0 router 5

R1 >R5 192.168.11.2/24

R5 >R6 192.168.16.1/24

R5 >R7 192.168.17.1/24

R5(config)#interface gigabitEthernet  0/0
R5(config-if)#ip address 192.168.11.2   255.255.255.0
R5(config-if)#no shutdown

R5(config)#interface gigabitEthernet  0/1
R5(config-if)#ip address 192.168.16.1   255.255.255.0
R5(config-if)#no shutdown

R5(config)#interface gigabitEthernet  0/2
R5(config-if)#ip address 192.168.17.1   255.255.255.0
R5(config-if)#no shutdown


## הגדרת ה OSPF
R5(config)#router ospf 1
R5(config-router)#network 192.168.11.0  0.0.0.255  area 0
R5(config-router)#network 192.168.12.0  0.0.0.255  area 1
R5(config-router)#network 192.168.13.0  0.0.0.255  area 1
R5(config-router)#network 192.168.16.0  0.0.0.255  area 2
R5(config-router)#network 192.168.17.0  0.0.0.255  area 2
R5(config-router)#router-id 5.5.5.5

Area 2 router 6

R6 >R5 192.168.16.2/24

R5(config)#interface gigabitEthernet  0/0
R5(config-if)#ip address 192.168.16.2   255.255.255.0
R5(config-if)#no shutdown



## הגדרת ה OSPF
R5(config)#router ospf 1
R5(config-router)#network 192.168.11.0  0.0.0.255  area 0
R5(config-router)#network 192.168.12.0  0.0.0.255  area 1
R5(config-router)#network 192.168.13.0  0.0.0.255  area 1
R5(config-router)#network 192.168.16.0  0.0.0.255  area 2
R5(config-router)#network 192.168.17.0  0.0.0.255  area 2
R5(config-router)#router-id 6.6.6.6

Area 2 router 7

R7 >R5 192.168.17.2/24

R5(config)#interface gigabitEthernet  0/0
R5(config-if)#ip address 192.168.17.2   255.255.255.0
R5(config-if)#no shutdown



## הגדרת ה OSPF
R5(config)#router ospf 1
R5(config-router)#network 192.168.11.0  0.0.0.255  area 0
R5(config-router)#network 192.168.12.0  0.0.0.255  area 1
R5(config-router)#network 192.168.13.0  0.0.0.255  area 1
R5(config-router)#network 192.168.16.0  0.0.0.255  area 2
R5(config-router)#network 192.168.17.0  0.0.0.255  area 2
R5(config-router)#router-id 7.7.7.7

לאחר הגגדרה ניתן לראות מ R5

את שאר הנתבים שמחברים עד לאזור 0

כעת שנעשה פינג לכל הרגלים לכל סגמנט בראוטר ניתן לראות שנגיע , לדוגמא ניקח את R7 ונראה אם אפשר לגשת לכל הראוטרים

בבדיקה דרך מאגר ה OSPF שלנו

או בפקודה נוספת……

ניתן לראות שאנחנו ניגשים להכול , כמובן שיש עוד הרבה שיטות להגדיר

נלמד בהמשך

כתיבת תגובה

האימייל לא יוצג באתר. שדות החובה מסומנים *

CAPTCHA